Azure Marketplace new offers – Volume 78

Azure Marketplace new offers – Volume 78

This article is contributed. See the original author and article here.

We continue to expand the Azure Marketplace ecosystem. For this volume, 56 new offers successfully met the onboarding criteria and went live. See details of the new offers below:

Applications

CiraSync.png

CiraSync: CiraSync from Cira Apps Limited quickly syncs the Office 365 global address list and public folder contacts to smartphones. It works with Azure Active Directory and features enterprise single sign-on and easy configuration.

CiraSync Contact Management (Single User).png

CiraSync Contact Management (Single User): This free, single-user version of CiraSync from Cira Apps Limited quickly syncs the Office 365 global address list and public folder contacts to smartphones. It works with Azure Active Directory and features enterprise single sign-on and easy configuration.

CSP Portal for ConnectWise and AutoTask.png

CSP Portal for ConnectWise and AutoTask: LANcom Technology’s CSP Portal syncs your customer cloud service provider (CSP) subscriptions to ConnectWise or AutoTask for automated invoicing, enabling you to save time, increase revenue, and redirect your resources to innovate and spend more time with customers.

DataVisor Feature Platform.png

DataVisor Feature Platform: DataVisor’s Feature Platform allows users to build sophisticated machine learning models, accelerate the feature engineering process from weeks to minutes, and rapidly deploy features in production. It supports real-time and batch processing, and it seamlessly integrates with your machine learning solutions.

Digital Insurance Middleware Platform.png

Digital Insurance Middleware Platform: InsureMO from eBaotech is a platform as a service that acts as middleware for the insurance industry, freeing insurers from legacy constraints and enabling them to effectively connect to stakeholders. Meet the demands of the digital age without investing in risky and expensive core system replacement.

e datascientist- Exploration.png

e[datascientist] – Exploration: Eagle Genomics’ e[datascientist] exploration module expands on the knowledge and reach of a single scientist or team of scientists to broaden the potential for innovation, reduce time to insight, and maximize the value of data from existing research.

ejudge - Online Judge for Code on Ubuntu.png

ejudge – Online Judge for Code on Ubuntu: ejudge is an easy-to-use contest management system for conducting programming tournaments and supporting training courses, where automatic checking of programs is required.

Enerfy Loyalty.png

Enerfy Loyalty: Use Enerfy Loyalty to reward auto insurance customers while gaining predictive insights that will take underwriting to a new level. Collect valuable customer data, increase customer satisfaction, strengthen customer retention, and gain new customers through peer recommendations.

Foxit Document Transformation Services.png

Foxit Document Transformation Services: Foxit’s Document Transformation Services (DTS) provides enterprise-class conversion and compression technology that integrates with document systems to improve business efficiency, ensure compliance, protect personally identifiable information (PII), and reduce cloud storage/egress costs.

FRISS Fraud Detection at Claims.png

FRISS Fraud Detection at Claims: FRISS Fraud Detection at Claims uses real-time AI fraud scoring to help property and casualty insurers during the claims process. High-risk claims are automatically flagged for investigation and sincere customers are swiftly served.

GrowthEnabler B2B Innovation Sourcing Marketplace.png

GrowthEnabler B2B Innovation Sourcing Marketplace: Source and manage innovative digital solutions with GrowthEnabler, an online B2B marketplace and objective decision insights platform. GrowthEnabler helps chief experience officers drive cross-functional team collaboration and engage with emerging disruptors.

Hyperledger Besu Quickstart.png

Hyperledger Besu Quickstart: Hyperledger Besu is an Ethereum-based blockchain using the standards developed by the Enterprise Ethereum Alliance. It’s compatible with Solidity smart contracts and is suited for enterprise use cases that require privacy, high throughput, and finality such as settlement, digital asset issuance, and payments.

ICTFAX - FAX Software Server for LINUX CentOS 7.7.png

ICTFAX – FAX Software Server for LINUX CentOS 7.7: This hardened image offered by Tidal Media is an email-to-fax, fax-to-email, and web-to-fax gateway application that supports extensions/ATA and REST APIs along with G.711 faxing, PSTN faxing, and FoIP T.38 origination and termination.

iSpring Suite Annual Subscription.png

iSpring Suite Annual Subscription: iSpring Suite is a Microsoft PowerPoint-based authoring toolkit from iSpring Solutions that enables users to create slide-based courses, quizzes, dialog simulations, screencasts, video lectures, and other interactive learning materials.

Jitsi Video Chat Server for Ubuntu 18.04 LTS.png

Jitsi Video Chat Server for Ubuntu 18.04 LTS: This offer from Tidal Media includes Jitsi, a ready-to-run and easy-to-maintain videoconferencing solution deployed on Ubuntu 18.04 LTS. Jitsi passes everyone’s video and audio to all participants rather than mixing them first, resulting in lower latency and better quality.

Kanboard - Kanban Project Management on Ubuntu.png

Kanboard – Kanban Project Management on Ubuntu: This Kanboard image offered by Tidal Media is an easy-to-use project management software solution using the Kanban methodology. Focusing on simplicity and minimalism, it presents all your important information in one place, including projects, calendar, assigned tasks, and subtasks.

Observa Artificial Intelligence.png

Observa Artificial Intelligence: Observa’s AI provides real-time insight into retail sales, marketing, and promotional campaigns. Ensure your pricing and promotions are accurate, and learn how you compare to your competition.

officeatwork- Uploader User Subscription.png

officeatwork | Uploader User Subscription: officeatwork is a Microsoft 365 solution containing apps and add-ins that provide Office 365 users with a simple way to create, upload, and update their Office 365 content. The Uploader comes with the Admin Center app, allowing administrators to configure the Uploader experience for all users.

ownCloud - File Sync and Share Server for Ubuntu.png

ownCloud – File Sync and Share Server for Ubuntu: This ready-to-run image from Tidal Media enables users to securely access and share data from anywhere on any device. ownCloud enterprise file sharing improves transparency, security, and control, and it can easily be integrated into your environment.

Phabricator - Git, Code, Manage Server for Ubuntu.png

Phabricator – Git, Code, Manage Server for Ubuntu: Phabricator is a set of tools for developing software. It includes apps that help users manage tasks and sprints; review code; host Git, SVN, or Mercurial repositories; build with continuous integration; and review designs.

SFTP - FTP Server for Windows Server 2019 OpenSSH.png

SFTP – FTP Server for Windows Server 2019 OpenSSH: This secure SFTP server solution uses SFTP/SSH server software, and the ready-to-use image offered by Tidal Media enables users to securely transfer data over the SSH protocol using AES, DES, and Blowfish encryption.

ShookIOT Essentials.png

ShookIOT Essentials: Simplify and accelerate your Industrial Internet of Things (IIOT) transformation journey with ShookIOT Essentials, an asset-centric, vendor-neutral object model that provides secure, fast, and reliable intelligence to all assets. Turn big data into insights across your industrial infrastructure and operations.

Simplifai Emailbot.png

Simplifai Emailbot: Simplifai Emailbot understands your inbound emails and triggers actions in back-end systems according to your business rules. It integrates with common email servers (Exchange, Gmail, and more) and can be configured to call any external API.

SymbioSys Commission-as-a-Service.png

SymbioSys Commission-as-a-Service: SymbioSys Commission-as-a-Service is a one-stop service for insurers that facilitates the configuration and administration of all types of simple and complex commission contracts. Maintain compliance and reduce the time and cost of administering diverse types of commissions without compromising accuracy.

Taiga Project Management Server for Ubuntu 16.04.png

Taiga Project Management Server for Ubuntu 16.04: Taiga Project Management Server for Ubuntu 16.04 is an open-source project management platform for Agile developers, designers, and project teams. This Taiga image offered by Tidal Media provides intuitive backlog and sprint planning.

Tuleap Agile Management Server on LINUX CentOS 7.7.png

Tuleap Agile Management Server on LINUX CentOS 7.7: Tuleap is an application lifecycle management system that facilitates the planning of software releases, the prioritization of business requirements, the assignment of tasks to project members, the monitoring of project progress, and the creation of reports.

Value Maximizer.png

Value Maximizer: Medisolv’s Value Maximizer uses AI to forecast payments in Centers for Medicare & Medicaid Services (CMS) hospital quality programs. Simulate your performance by measure in each program, and learn which measures need to be improved to maximize your incentive payments.

Virtual Assist.png

Virtual Assist: Suitable for insurance companies, facility maintenance teams, and property managers, Codafication’s Virtual Assist provides a secure way for people and businesses to share their stories instantly via video. Improve customer service and performance score cards while mitigating risk and increasing safety.

Xlight FTP Server for Windows Server 2019.png

Xlight FTP Server for Windows Server 2019: This offer from Tidal Media includes Xlight FTP Server for Windows Server 2019, an easy-to-use high-performance FTP server with low CPU usage. Features include remote administration, SSL, SFTP, ODBC, LDAP, Active Directory support, and IPv6 support.

Consulting services

Azure Virtual Network Endpoints.png

Azure Virtual Network Endpoints: Extend your virtual network private address space with Microsoft Azure Virtual Network (VNet) service endpoint policies managed by KoçSistem’s experts. This offer includes 24/7 system monitoring, testing, and more.

Custom Software Development- 2 Hour-Assessment.png

Custom Software Development: 2 Hour-Assessment: Join Tech Fabric LLC’s enterprise architect and chief sales officer for a free custom software development consultation. You’ll learn about Tech Fabric’s microservices and API-led connectivity approach, the benefits of Microsoft Azure, and more.

Free 5 Day Azure Analytics Services Assessment UK.png

Free 5 Day Azure Analytics Services Assessment UK: Zensar Technologies will assess your analytics investments and landscape, discuss your business objectives, and work with you to create a custom Azure analytics solution architecture. This offer is for customers in the United Kingdom.

Free 5 day Azure Migration Assessment Offer UK.png

Free 5 day Azure Migration Assessment Offer UK: Zensar Technologies will review your applications estate (servers, database, web apps, and data) and deliver a detailed roadmap to initiate an applications migration to the cloud. This offer is for customers in the United Kingdom.

KoçSistem Azure Active Directory & DirSync.png

KoçSistem Azure Active Directory & DirSync: KoçSistem’s expert managed services team will use Microsoft Azure tools to monitor your systems 24/7 based on defined metrics. Easily manage identities with Azure Active Directory, DirSync services, and KoçSistem’s assistance.

KoçSistem Azure App Service.png

KoçSistem Azure App Service: In this offer, KoçSistem will integrate Microsoft Azure applications with your SaaS platforms and on-premises data sources. KoçSistem will also manage role-based access, define automation for scaling, and monitor system health and performance.

KoçSistem Azure Application Gateway.png

KoçSistem Azure Application Gateway: Manage traffic to your web applications with Microsoft Azure Application Gateway and KoçSistem’s managed services team. KoçSistem will monitor your systems and route definitions of customer web applications according to requests.

KoçSistem Azure Backup Management.png

KoçSistem Azure Backup Management: Simplify your data recovery processes with KoçSistem’s 24/7 management of Microsoft Azure Backup services. In addition to system monitoring, KoçSistem will create and plan business continuity and disaster recovery scenarios.

KoçSistem Azure CDN.png

KoçSistem Azure CDN: Efficiently deliver web content to your users with Microsoft Azure Content Delivery Network and the assistance of KoçSistem. This offer includes management and implementation of Azure CDN, along with ongoing help desk services.

KoçSistem Azure Container Service (AKS).png

KoçSistem Azure Container Service (AKS): Let KoçSistem manage your company’s usage of Microsoft Azure Kubernetes Service. This offer features DevOps deployment strategies, cluster version upgrades, cluster security, storage structure, rollback management, and more.

KoçSistem Azure Database Management.png

KoçSistem Azure Database Management: KoçSistem’s team will manage and monitor your Microsoft Azure database services, involving performance analysis and error analysis. KoçSistem supports Azure SQL Managed Instance, Azure Cache for Redis, Azure Cosmos DB, and several other database systems.

KoçSistem Azure DNS.png

KoçSistem Azure DNS: In this offer, KoçSistem’s expert network managed services team will manage your Microsoft Azure DNS hosting operations and provide ongoing help desk support for outages or degraded service.

KoçSistem Azure Express Route.png

KoçSistem Azure Express Route: In this managed service, KoçSistem will provide real-time monitoring of your Microsoft Azure ExpressRoute connection. This offer includes design, deployment, configuration, migration, and management of Azure ExpressRoute.

KoçSistem Azure Key Vault Management.png

KoçSistem Azure Key Vault Management: Increase security and control over your keys and passwords with Azure Key Vault services managed by KoçSistem. In addition to 24/7 monitoring, KoçSistem will handle all necessary classifications and authorizations in Azure Key Vault access.

KoçSistem Azure MFA Management.png

KoçSistem Azure MFA Management: In this offer, KoçSistem will manage your Microsoft Azure Multi-Factor Authentication (MFA), assigning licenses, blocking or unblocking users, updating safe IP lists, and making configuration changes.

KoçSistem Azure Monitoring & Automation.png

KoçSistem Azure Monitoring & Automation: In this managed service, KoçSistem’s team will use Microsoft Azure tools, including Azure Monitor and Azure Log Analytics, to monitor and automate your applications, infrastructure, and network.

KoçSistem Azure Network Security Groups.png

KoçSistem Azure Network Security Groups: Using Azure network security groups, KoçSistem’s expert managed services team will manage your network traffic, filter your networks, and communicate with your on-premises resources.

KoçSistem Azure Network Watcher.png

KoçSistem Azure Network Watcher: In this offer, KoçSistem’s team will manage Microsoft Azure Network Watcher for your organization, performing diagnostics tests and more to increase your network performance.

KoçSistem Azure Security Center Managed Service.png

KoçSistem Azure Security Center Managed Service: Get hybrid security management and threat protection with Microsoft Azure Security Center services managed by KoçSistem’s team of experts. This offer includes installation and distribution for on-premises systems.

KoçSistem Azure Storage Management.png

KoçSistem Azure Storage Management: Reduce investment costs and reduce your datacenter storage management responsibilities with the help of KoçSistem’s managed services team, who will help you handle your Microsoft Azure storage and database services.

KoçSistem Azure Traffic Manager.png

KoçSistem Azure Traffic Manager: Allow KoçSistem to manage Microsoft Azure Traffic Manager for your organization so you can achieve higher availability and faster response time. KoçSistem will create profiles, add endpoints, test functionality, and manage DNS controls.

KoçSistem Azure Virtual Machines.png

KoçSistem Azure Virtual Machines: In this offer, KoçSistem will manage your organization’s use of Microsoft Azure Virtual Machines, handling capacity operations and adding, removing, and updating storage units. Benefit from an on-demand, highly scalable, and protected virtualized infrastructure.

KoçSistem Azure Virtual Network (VNet).png

KoçSistem Azure Virtual Network (VNet): In this managed service, KoçSistem will monitor your Microsoft Azure Virtual Network (VNet) usage based on defined metrics. Incidents will be automatically launched in case of any problem with the system.

KoçSistem Azure Virtual Network TAP.png

KoçSistem Azure Virtual Network TAP: Continuously mirror traffic from a virtual network to a packet collector with Microsoft Azure virtual network Terminal Access Point (TAP) managed by KoçSistem’s team of experts. KoçSistem will provide ongoing help desk services and CDN management.

KoçSistem Azure Virtual Private Network.png

KoçSistem Azure Virtual Private Network: In this offer, KoçSistem’s team will handle Azure Virtual Private Network (VPN) services, including continuity management and transmitting information for tunnels to be created over a VPN gateway.

KoçSistem Azure Virtual WAN.png

KoçSistem Azure Virtual WAN: Optimize and automate branch connectivity with Microsoft Azure Virtual WAN managed by KoçSistem. This offer includes full-time monitoring, addition mapping, service pack changes, and more.

Oracle on Azure- 14-Day Implementation.png

Oracle on Azure: 14-Day Implementation: Asseco Data Systems’ Oracle to Microsoft Azure migration service is designed for users who seek high performance and scalability with full engineering support, troubleshooting, and cost optimization.

Voice of #HealthcareCloud brought to you by Shelly & Vasu – Session 3: “The Power of the Platform”

Voice of #HealthcareCloud brought to you by Shelly & Vasu – Session 3: “The Power of the Platform”

This article is contributed. See the original author and article here.

Blog Title Image.jpg

 

Voices of #HealthcareCloud is a webinar series hosted by myself and Vasu Sharma. My name is Shelly Avery, I am currently a Microsoft Teams Technical Specialist for Health and Life Sciences. Vasu is a Customer Success Manager for Microsoft 365 for Health and Life Sciences. Our goal of this webinar series is to showcase how Healthcare is seeing positive business and clinical outcomes with cloud technology.

 

We will be bringing new and creative solutions to you at least once a month so we hope you tune in live or catch the on-demand series after the session is completed.

 

For this session we are excited to showcase 3 unique solutions that all provide much needed solutions in the Clinical, Operational and Financial side of the business for our Providers. Please tune in Tuesday July 21st at 10:00 PT/ 12:00 CT/ 1:00 ET to hear about:

  • Hand Hygiene automation presented by Tyler Durham
  • Emergency response application presented by Chauncy Larson  
  • Building Access application presented by Pawan Gulati

 

Please join us Live Tuesday July 21st at 10:00 PT/ 12:00 CT/ 1:00 ET for to hear from our Presenters who were a part of the development of each of these solutions.  

 

Download calendar invite here to add to your calendar

 

Click to join the Live event here

 

Presenters:

Tyler Durham.jpgTyler Durham, Sr Technical Specialist for Health & Life Sciences

Chauncy Larson.jpgChauncy Larson, Sr Technical Specialist for Health & Life Sciences

Pawan Gulati.jpgPawan Gulati, Customer Success Director for Health & Life Sciences

Creating a Custom Dashboard for Azure Security Center with Azure Resource Graph

Creating a Custom Dashboard for Azure Security Center with Azure Resource Graph

This article is contributed. See the original author and article here.

While the Azure Security Center dashboard is extremely rich with detail information about different workloads, recommendations, and alerts, in some scenarios you may need to customize your dashboard to visualize only what is important for your daily activities.

 

ARG basics for Azure Security Center

 

Azure Resource Graph (ARG) provides an efficient way to query at scale across a given set of subscriptions for any Azure Resource. With ARG, you can query, visualize, or export Azure Security Center (ASC) recommendations in order to get the information that matters most to you.

 

In the Azure Portal, navigate to Resource Graph Explorer and get familiar with the different options. You can create and save your favourite queries, export results into CSV and even pin them into your Azure Dashboard. Bellow you can see a very basic ARG query that will return the Azure Security Center recommendations from the selected subscriptions and arrange information in a more readable manner.

Img1.png

 

securityresources
 | where type == "microsoft.security/assessments"
 // Get recommendations in useful format
 | project
	['TenantID'] = tenantId,
	['SubscriptionID'] = subscriptionId,
	['AssessmentID'] = name,
	['DisplayName'] = properties.displayName,
	['ResourceType'] = tolower(split(properties.resourceDetails.Id,"/").[7]),
	['ResourceName'] = tolower(split(properties.resourceDetails.Id,"/").[8]),
	['ResourceGroup'] = resourceGroup,
	['ContainsNestedRecom'] = tostring(properties.additionalData.subAssessmentsLink),
	['StatusCode'] = properties.status.code,
	['StatusDescription'] = properties.status.description,
	['PolicyDefID'] = properties.metadata.policyDefinitionId,
	['Description'] = properties.metadata.description,
	['RecomType'] = properties.metadata.assessmentType,
	['Remediation'] = properties.metadata.remediationDescription,
	['RemediationEffort'] = properties.metadata.implementationEffort,
	['Severity'] = properties.metadata.severity,
	['Categories'] = properties.metadata.categories,
	['UserImpact'] = properties.metadata.userImpact,
	['Threats'] = properties.metadata.threats,
	['Link'] = properties.links.azurePortal

 

A Starter kit has been published in the Azure Security Center Github Community page to help you get familiar with recommendations as well as the data structure from Azure Security Center. Just copy/paste the ARG queries and start to customize them to your needs.

 

Img2.png

 

Creating your custom Dashboard

 

One of the coolest features of ARG, is that, apart from querying and exporting your results, you can easily create charts and dashboards directly from the Azure Resource Graph Explorer console and even pin them directly into your Azure Portal. 

 

Let’s use one of the samples from the GIthub repo to query for High Severity and Low Remediation Effort recommendations.  

 

Img3.png

 

By simply adding a few lines to the initial examples shared above, we were able to build different views summarizing:

 

Threat vectors identified

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"
// summarize and order
 | summarize count() by tostring(Threats)
 | order by count_

 

 

Type of impacted resources

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"
// summarize and order
 | summarize count() by tostring(Categories)
 | order by count_

 

 

List of recommendations

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"

 

 

List of impacted resources

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"
// summarize and order
 | summarize count() by ResourceName, ResourceType
 | order by count_

 

 

Impacted subscriptions by threat vector

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"
// summarize and order
 | summarize count() by SubscriptionID
 | order by count_

 

 

Impacted resource group by threat vector

 

// Filter
 | where Severity == "High"
 | where RemediationEffort == "Low"
// summarize and order
 | summarize count() by ResourceGroup
 | order by count_

 

Additional Resources

  • ARG Starter Kit Github community – Link
  • Azure Resource Graph – Link
  • Azure Resource Graph API – Link

 

Reviewers

Special thanks to:

Yuri Diogenes, @Yuri Diogenes, Senior Program Manager (CxE ASC Team)

Tal Rosler, @tal_rosler, Program Manager (ASC Engineering Team)

Experiencing Data Access Issue in Azure portal for Log Analytics – 07/13 – Investigating

This article is contributed. See the original author and article here.

Initial Update: Monday, 13 July 2020 10:53 UTC

We are aware of issues within Azure Monitoring and are actively investigating. Some customers may experience missing alerts in a partner solution (Example: service now).

  • Work Around: None
  • Next Update: Before 07/13 13:00 UTC

We are working hard to resolve this issue and apologize for any inconvenience.
-Anmol


Microsoft Endpoint Manager: Create & Audit an ASR Policy

Microsoft Endpoint Manager: Create & Audit an ASR Policy

This article is contributed. See the original author and article here.

Introduction
This is John Barbare and I am a Sr Premier Field Engineer at Microsoft focusing on all things in the Cybersecurity space. In this tutorial I will walk you through the steps of creating an Attack Surface Reduction (ASR) rule policy in Microsoft Endpoint Manager (MEM) for your Windows Operating Systems and how to view the detections once applied.

 

In the last series, I gave an in depth overview of MEM, the licensing, several features it has to assist IT professionals, and then walked you through the steps of creating a Windows Defender Antivirus policy. I hope you found the first series beneficial as this series will add on to securing and protecting your overall attack surface. By creating and configuring a new ASR rule policy in MEM, this will further strengthen your overall security posture. It’s recommended to test in Audit mode before you decide and enable any of the ASR rules in enforce mode.

 

Microsoft recommends a balanced and pragmatic approach focused on reducing the overall attack surface. Implementing ASR rules is a great place to start. The picture below illustrates the threat protection life cycle. You will learn about each stage so you will be fully protected once you find out which ASR rules will lower your overall attack surface through Audit mode and be able to turn on different ones in enforce mode.

Threat Protection LifecycleThreat Protection Lifecycle

 

What are Attack Surface Reduction Rules?
Attack surface reduction rules help prevent software behaviors that are often abused to compromise your device or network. For example, an attacker might try to run an unsigned script off a USB drive, or have a macro in an Office document make calls directly to the Win32 API. ASR rules can constrain these kinds of risky behaviors and improve your organization’s defensive posture to decrease your risk considerably from being attacked with Ransomware, various other types of malware, and other attack vectors.

 

If you are evaluating or executing a proof of concept from a 3rd party HIPS (Host Intrusion Prevention System) over to ASR rules, this article will assist you in the planning, development, and proper configuration in MEM. With the complete end to end protection Microsoft offers, this article will focus on the Attack Surface Reduction component of Windows Defender Exploit Guard as shown below in the green box.

 

Exploit Guard - Attack Surface ReductionExploit Guard – Attack Surface Reduction

 

You can learn more on how to customize ASR rules by excluding files and folders or adding custom text to the notification alert that appears on a user’s computer.

 

You can set ASR rules for devices running any of the following editions and versions of Windows:

 

ASR rules contain over a dozen configurable rules that can enable or disable specific behaviors. These rules do the following:

 

  • Prevent actions and apps that are commonly used by malware, such as launching executables from email (.exe, .dll, .scr, .ps, .vbs, and .js)
  • Scripts or applications that launch child processes
  • Most rules can be set to Audit to monitor activity prior to being set to enforce
  • All rules support exclusions based on file or folder names
  • ASR rules support environmental variables and wildcards

ASR rules may block legitimate applications from making changes, so these features come with both an Audit mode and a Block mode. I always recommend to my customers when configuring ASR rules for the first time to conduct the changes in Audit mode first so it will allow for testing of the policy before moving any of the rules into Block mode.

 

List of all the ASR Rules

ASR rules are designed to help your organization reduce the overall attack surface of an endpoint by minimizing the locations where cyberthreats, malware, attacks, and Ransomware tends to emerge from. ASR rules fall into specific categories which are Microsoft Office, email based, Windows Management Interface (WMI) based, executable and script based, 3rd party application based, Windows credentials based, and device control based. All ASR rules, except for Block persistence through WMI event subscription, are supported on Windows 1709 and later.

Below is a chart displaying each ASR rule in the respective categories.

 

ASR CategoriesASR Categories

 

Each ASR rule contains three settings:
1. Not configured: Disable the ASR rule
2. Block: Enable the ASR rule
3. Audit Mode: Evaluate how the ASR rule would impact your organization if enabled

Office Files Example
Smart ASR control provides the ability to block behavior that balances security and productivity. In the image below you can see how an Office file can be detected from malicious content by using ASR rules and Windows Defender Exploit Guard.

 

Office Files ExampleOffice Files Example

 

Creating a new ASR Rule Policy
The first item we want to do is make sure that all the devices we want to push the new ASR rule policy are showing up inside MEM admin center. This paper assumes you have enrolled all the devices for your preferred method, and we are checking to make sure the devices are shown before creating or pushing out a new policy.

 

Navigate to the Microsoft Endpoint Manager admin center and login with your credentials https://endpoint.microsoft.com.

 

Login ScreenLogin Screen

 

Once logged in you will arrive at the home page.

 

Home page of Microsoft Endpoint ManagerHome page of Microsoft Endpoint Manager

 

Select “Devices” and then “All devices” to make sure the device you will be applying the new ASR rule Policy has been synced.

 

Selecting the All Devices TabSelecting the All Devices Tab

 

Next, we will select the “Endpoint Security” tab which is under the “Device” tab.

 

Endpoint Security TabEndpoint Security Tab

 

This will bring you into the main policy dashboard to create the new ASR rule policy. First you will select “Attack Surface Reduction” under the “Manage” tab. Select “create policy” at the top, and then a window will open to pick the operating system “Platform” and “Profile”. For “Platform”, select Windows 10 and later and for “Profile”, select Microsoft Defender Antivirus and click “Create” at the bottom.

 

Creating the ASR PolicyCreating the ASR Policy

 

This will bring you to the creation of the profile for ASR. Name the profile in the “basics” tab and then provide a brief description and click next.

 

Creating the ProfileCreating the Profile

 

Configuration Settings

The next tab, “Configuration settings” is where you will configure the ASR rules. Always place each rule in Audit first to monitor for testing of the policy before moving any of the rules into Enable (Block) mode. You can also search for a setting in the top box underneath the settings and before the ASR rules.

 

Configuring Settings for the ASR PolicyConfiguring Settings for the ASR Policy

 

Once finished with setting the rules in Audit mode, one can add Exclude files and paths from attack surface reduction rules (declare files and folders that are excluded from configured ASR rules).

Added in Windows 10, version 1709. This policy setting allows you to prevent ASR rules from matching on files under the paths specified or for the fully qualified resources specified. Paths should be added under the Options for this setting. Each entry must be listed as a name value pair, where the name should be a string representation of a path or a fully qualified resource name.

 

As an example, a path might be defined as: “c:Windows” or “C:UsersjobarbarDocumentsPen_TestingRed_Team_Attack_Tools” to exclude all files in this directory. A fully qualified resource name might be defined as: “C:WindowsApp.exe”. Once finished with the ASR profile and settings, click next.

 

Add Folder ExclusionsAdd Folder Exclusions

 

I have several clients that always ask which ASR rules do you or Microsoft recommend we enforce even after testing. Every customer environment is different both in the architectural design and what is allowed or not allowed in the environment which might cause a line of business application to not work. Microsoft recommends enabling all ASR rules, but every case and customer is different. If you are still using Microsoft Endpoint Configuration Manager to manage your endpoints, then enabling the “Block process creations originating from PSExec and WMI commands” ASR rule should not be enabled. During your testing in Audit mode, please read and become familiar with what each ASR rule does and what it is designed to do on Microsoft’s ASR Rule documentation page to give an idea of what it will prevent.

 

Scope Tags

In the next window you will select any scope tags you have assigned for any of your devices and click next.

 

Selecting Scope TagsSelecting Scope Tags

 

When you create or update a profile, you can add scope tags and applicability rules to the profile.

Scope tags are a great way to filter profiles to specific groups. Some would include scope tags such as The_Citadel IT Team, Mr_Robot_ITDepartment, or Test-OU. Use RBAC and scope tags for distributed IT which has more information.

 

On Windows 10 devices, you can add applicability rules so the profile only applies to a specific OS version or a specific Windows edition. Applicability rules has more information.

 

Assignments

Next, we will have the option to assign the policy to select groups, all users, all devices, or all users and devices. Here we are targeting just a select group and will pick the IT Group for this new policy. Selecting the groups to include and IT Group will target the devices inside the group and then click select and then click next. This is the equivalent to applying a policy to an organizational unit in Group Policy Objects.

 

Targeting the Assignments for the ASR PolicyTargeting the Assignments for the ASR Policy

 

Many users ask when to use user groups and when to use device groups. The answer depends on your goal. Here is some guidance to get you started.

 

Device groups
If you want to apply settings on a device, regardless of who’s signed in, then assign your profiles to a devices group. Settings applied to device groups always go with the device, not the user.
Device groups are useful for managing devices that don’t have a dedicated user. For example, you have devices that print tickets, scan inventory, are shared by shift workers, are assigned to a specific warehouse, and so on. Put these devices in a devices group, and assign your profiles to this devices group.

User groups

Profile settings applied to user groups always go with the user, and go with the user when signed in to their many devices. It’s normal for users to have many devices, such as a Surface Pro for work, and a personal iOS/iPadOS device. And, it’s normal for a person to access email and other organization resources from these devices.

 

For example: You want to put a Help Desk icon for all users on all their devices. In this scenario, put these users in a users group, and assign your Help Desk icon profile to this users group.

 

To summarize, use device groups when you don’t care who’s signed in on the device, or if anyone is signed in. You want your settings to always be on the device. Use user groups when you want your settings and rules to always go with the user, whatever device they use.

 

Review and Create

Now let’s head over to finalizing up the newly created profile on the review and create profile page. You will see all the settings for the new ASR policy, and you can confirm before selecting create. I’ve attached two screenshots of the review + create section as all the ASR rule basics and configuration settings can’t be viewed in one screenshot.

 

Summary of the new ASR PolicySummary of the new ASR Policy

 

After scrolling down one can see the rest of the configuration settings to make sure everything is correct before deploying out the new ASR rule policy. Go ahead and click on create to save the new ASR policy.

 

Summary of the new ASR PolicySummary of the new ASR Policy

 

The next page will bring you to the summary page where you can view the new ASR rule policy you just created. When you select the policy name that you have created, you will be redirected to the overview page which will display more detailed information.

 

Showing The New ASR PolicyShowing The New ASR Policy

 

When you select a tile from this view, MEM displays additional details for that profile if they are available. In this case, it applied my new ASR rule policy to all devices I targeted successfully.

 

Viewing the newly applied ASR Policy to the targeted machinesViewing the newly applied ASR Policy to the targeted machines

 

Monitoring the ASR Rules in Audit Mode in Microsoft Defender ATP

Microsoft Defender ATP provides detailed reporting for events and blocks, as part of its alert investigation scenarios.

 

You can query Microsoft Defender ATP data by using advanced hunting. If you are running Audit mode, you can use advanced hunting to understand how attack surface reduction rules could affect your environment.

 

Login into https://securitycenter.windows.com and click on the advanced hunting tab.

 

Advanced Hunting in MDATP for ASR EventsAdvanced Hunting in MDATP for ASR Events

 

On the far right, you can change the time from last 24 hours, last 7 days, last 30 days, or a custom time range of your choosing. Click on the Query tab and type in the following query to search for all ASR rule events in Audit mode to see what is impacting your environment and which ASR rules are getting triggered.

 

DeviceEvents

| where ActionType startswith ‘Asr’

 

Click on the blue tab “Run Query” to see the results.

 

Results of QueryResults of Query

 

Once the results are displayed, you can filter out the columns in your report by selecting the customize columns. On the far right of the screen you see all the filters you can apply and scrolling down will show many more. As we take a look at the ASR rule Audit report, we can see the “Action Type” is the ASR rule that was audited and then the file name, folder path, and other columns in the report.

 

Clicking on the Export tab will download a .csv file with all the information included in the query as shown on the screen.

 

Clicking on the Chart type, you can view all the data in a table, column chart, stacked column chart, pie chart, donut chart, line chart, scatter chart, and area chart. Depending on how you want to view your data, it will display in each chart type as seen below.

 

Selecting the Chart TypeSelecting the Chart Type

 

Selecting the line chart, one can see each ASR rule Audit detections over a period of time. This is all customizable and can be exported in a .jpg file to include on a weekly update report to upper management.

 

ASR Detections in the Populated ChartASR Detections in the Populated Chart

 

For more information on advanced hunting, visit Microsoft’s documentation page.

 

Monitoring the ASR Rules in Audit Mode in Microsoft Threat Protection (MTP)

Login into https://security.microsoft.com and click on the Reports tab and view the ASR rules that are in Audit mode (blue) and any that are in Block mode (purple).

 

Microsoft Threat Protection ASR EventsMicrosoft Threat Protection ASR Events

 

Click on the view detections tab to see a more fine-grained ASR rule detection graph in Audit and Block mode over a period time and what has been detected.

 

Viewing Audit  Events in the TimelineViewing Audit Events in the Timeline

 

Many other methods exist to see what ASR rules are being audited in your environment. Since I mainly work with Microsoft Defender ATP and Microsoft Threat Protection with my customers, this is the primary way I view the detections. If you would like to use event viewer, you can create a custom view for the ASR rules by following the below steps:

 

  1. Type event viewer in the Start menu and open the Windows Event Viewer.
  2. On the left panel, under Actions, click Create Custom View.

Creating Custom ASR ViewCreating Custom ASR View

 

  1. Go to the XML tab and click Edit query manually. You’ll see a warning that you won’t be able to edit the query using the Filter tab if you use the XML option. Click Yes.
  2. Paste the following XML code to filter only ASR rule events into the XML section.

<QueryList>

  <Query Id=”0″ Path=”Microsoft-Windows-Windows Defender/Operational”>

   <Select Path=”Microsoft-Windows-Windows Defender/Operational”>*[System[(EventID=1121 or EventID=1122 or EventID=5007)]]</Select>

   <Select Path=”Microsoft-Windows-Windows Defender/WHC”>*[System[(EventID=1121 or EventID=1122 or EventID=5007)]]</Select>

  </Query>
</QueryList>

 

  1. Click OK. Specify a name for your filter – ASR rule events.
  2. This will create a custom view that filters to only show the events related to that feature. Under custom views in event viewer you will see all the ASR rules that have been audited (event 1122).

 

Event ID

Description

5007

Event when settings are changed

1121

Event when rule fires in Block-mode

1122

Event when rule fires in Audit-mode

 

List of attack surface reduction events

All attack surface reduction events are located under Applications and Services Logs – Microsoft – Windows and then the folder or provider as listed in the following table.

 

You can access these events in Windows Event viewer:

 

  1. Type event viewer in the Start menu and open the Windows Event Viewer.
  2. Expand Applications and Services Logs – Microsoft – Windows and then go to the folder listed under Provider/source.
  3. Double-click on the sub item to see events. Scroll through the events to find the one you are looking.

Viewing the ASR EventsViewing the ASR Events

 

Conclusion
Thanks for taking the time to read this article and I hope you had fun reading how to create an ASR rule policy using the new MEM console and how to see what processes are being audited in your environment using Microsoft Defender ATP, Microsoft Threat Protection, or event viewer. The next series I will show you how to setup, configure, and then deploy out Microsoft Defender ATP to your endpoints in MEM. Hope to see you in the next series and always protect your endpoints!

 

Thanks for reading and have a great Cybersecurity day!